Skip to content

Commit a61d156

Browse files
committed
pypi-keyring: Autospec creation for update from version 23.5.0 to version 23.5.1
Anderson Bravalheri (1): Ignore flake8/black warnings with pytest 7.0.1 (jaraco/skeleton#58) Dave Gaeddert (1): Add .coverage.* to gitignore Dos Moonen (4): Add failing test for keyring.util.platform_.config_root Fix keyring.util.platform_.config_root on Windows Added entry in CHANGES.rst Use Pytest's skipif decorator instead of returning to skip assert statements. Jason R. Coombs (9): Update badge year Remove setup.py, no longer needed. Add exclusions for pytest 7 deprecations in plugins. Fixes jaraco/skeleton#57. Use the parent category PytestDeprecationWarning, which is available on older pytest versions. Fixes jaraco/skeleton#57. Bump pytest-mypy and remove workaround for realpython/pytest-mypy#131. Require jaraco.packaging 9 adding compatibility for projects with no setup.py file. Ran pre-commit autoupdate Use actual version number. Trim test down. Sviatoslav Sydorenko (1): Inject check job into CI workflow as ultimate flag (#55)
1 parent 667ff32 commit a61d156

File tree

6 files changed

+35
-14
lines changed

6 files changed

+35
-14
lines changed

Makefile

Lines changed: 1 addition & 1 deletion
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
11
PKG_NAME := pypi-keyring
2-
URL = https://files.pythonhosted.org/packages/22/2b/e840597838cc63f96926bd7daca67936031635cfe6c81ee12dc652bd2dce/keyring-23.5.0.tar.gz
2+
URL = https://files.pythonhosted.org/packages/0b/c6/87aaea22b32a85c1eb786ee77844f826103e65e9c0a0c4df1f95ec23d3be/keyring-23.5.1.tar.gz
33
ARCHIVES =
44

55
include ../common/Makefile.common

options.conf

Lines changed: 1 addition & 1 deletion
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
[package]
22
name = pypi-keyring
3-
url = https://files.pythonhosted.org/packages/22/2b/e840597838cc63f96926bd7daca67936031635cfe6c81ee12dc652bd2dce/keyring-23.5.0.tar.gz
3+
url = https://files.pythonhosted.org/packages/0b/c6/87aaea22b32a85c1eb786ee77844f826103e65e9c0a0c4df1f95ec23d3be/keyring-23.5.1.tar.gz
44
archives =
55
giturl = https://github.com/jaraco/keyring/
66
domain =

pypi-keyring.spec

Lines changed: 30 additions & 9 deletions
Original file line numberDiff line numberDiff line change
@@ -3,13 +3,13 @@
33
# Generated by: autospec.py
44
#
55
Name : pypi-keyring
6-
Version : 23.5.0
7-
Release : 115
8-
URL : https://files.pythonhosted.org/packages/22/2b/e840597838cc63f96926bd7daca67936031635cfe6c81ee12dc652bd2dce/keyring-23.5.0.tar.gz
9-
Source0 : https://files.pythonhosted.org/packages/22/2b/e840597838cc63f96926bd7daca67936031635cfe6c81ee12dc652bd2dce/keyring-23.5.0.tar.gz
6+
Version : 23.5.1
7+
Release : 116
8+
URL : https://files.pythonhosted.org/packages/0b/c6/87aaea22b32a85c1eb786ee77844f826103e65e9c0a0c4df1f95ec23d3be/keyring-23.5.1.tar.gz
9+
Source0 : https://files.pythonhosted.org/packages/0b/c6/87aaea22b32a85c1eb786ee77844f826103e65e9c0a0c4df1f95ec23d3be/keyring-23.5.1.tar.gz
1010
Summary : Store and access your passwords safely.
1111
Group : Development/Tools
12-
License : MIT
12+
License : MIT Python-2.0
1313
Requires: pypi-keyring-bin = %{version}-%{release}
1414
Requires: pypi-keyring-license = %{version}-%{release}
1515
Requires: pypi-keyring-python = %{version}-%{release}
@@ -68,15 +68,18 @@ python3 components for the pypi-keyring package.
6868

6969

7070
%prep
71-
%setup -q -n keyring-23.5.0
72-
cd %{_builddir}/keyring-23.5.0
71+
%setup -q -n keyring-23.5.1
72+
cd %{_builddir}/keyring-23.5.1
73+
pushd ..
74+
cp -a keyring-23.5.1 buildavx2
75+
popd
7376

7477
%build
7578
export http_proxy=http://127.0.0.1:9/
7679
export https_proxy=http://127.0.0.1:9/
7780
export no_proxy=localhost,127.0.0.1,0.0.0.0
7881
export LANG=C.UTF-8
79-
export SOURCE_DATE_EPOCH=1649777144
82+
export SOURCE_DATE_EPOCH=1653336156
8083
export GCC_IGNORE_WERROR=1
8184
export AR=gcc-ar
8285
export RANLIB=gcc-ranlib
@@ -87,6 +90,15 @@ export FFLAGS="$FFLAGS -O3 -ffat-lto-objects -flto=auto "
8790
export CXXFLAGS="$CXXFLAGS -O3 -ffat-lto-objects -flto=auto "
8891
export MAKEFLAGS=%{?_smp_mflags}
8992
python3 -m build --wheel --skip-dependency-check --no-isolation
93+
pushd ../buildavx2/
94+
export CFLAGS="$CFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
95+
export CXXFLAGS="$CXXFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
96+
export FFLAGS="$FFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
97+
export FCFLAGS="$FCFLAGS -m64 -march=x86-64-v3 "
98+
export LDFLAGS="$LDFLAGS -m64 -march=x86-64-v3 "
99+
python3 -m build --wheel --skip-dependency-check --no-isolation
100+
101+
popd
90102

91103
%check
92104
export http_proxy=http://127.0.0.1:9/
@@ -97,11 +109,20 @@ python setup.py ptr || :
97109
export MAKEFLAGS=%{?_smp_mflags}
98110
rm -rf %{buildroot}
99111
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-keyring
100-
cp %{_builddir}/keyring-23.5.0/LICENSE %{buildroot}/usr/share/package-licenses/pypi-keyring/8e6689d37f82d5617b7f7f7232c94024d41066d1
112+
cp %{_builddir}/keyring-23.5.1/LICENSE %{buildroot}/usr/share/package-licenses/pypi-keyring/8e6689d37f82d5617b7f7f7232c94024d41066d1
101113
pip install --root=%{buildroot} --no-deps --ignore-installed dist/*.whl
102114
echo ----[ mark ]----
103115
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
104116
echo ----[ mark ]----
117+
pushd ../buildavx2/
118+
export CFLAGS="$CFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
119+
export CXXFLAGS="$CXXFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
120+
export FFLAGS="$FFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
121+
export FCFLAGS="$FCFLAGS -m64 -march=x86-64-v3 "
122+
export LDFLAGS="$LDFLAGS -m64 -march=x86-64-v3 "
123+
pip install --root=%{buildroot}-v3 --no-deps --ignore-installed dist/*.whl
124+
popd
125+
/usr/bin/elf-move.py avx2 %{buildroot}-v3 %{buildroot}/usr/share/clear/optimized-elf/ %{buildroot}/usr/share/clear/filemap/filemap-%{name}
105126

106127
%files
107128
%defattr(-,root,root,-)

release

Lines changed: 1 addition & 1 deletion
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
115
1+
116

upstream

Lines changed: 1 addition & 1 deletion
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
bec0f73355b3a95df95769b80980cb8b5ca8dd57/keyring-23.5.0.tar.gz
1+
89f9754ddc5bf93f3b1b1fe83606aca06d130ae1/keyring-23.5.1.tar.gz

versions

Lines changed: 1 addition & 1 deletion
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
23.5.0
1+
23.5.1

0 commit comments

Comments
 (0)