Skip to content

Commit 357c58b

Browse files
committed
pypi-pydantic: Autospec creation for update from version 2.0.1 to version 1.10.10
Adrian Garcia Badaracco (1): Support for email-validator>=2.0.0.post2 (#5627) Amin Alaee (1): Remove pkg_resources test (#5508) Arseny Boykov (1): [1.10.x] Properly encode model and dataclass default for schema (#4781) Bas Schoenmaeckers (1): Add future and past date hypothesis strategies (#5850) Benoit C. Sirois (1): Fixes discriminated unions not working on aliased literal fields. Issue #3849. (#5736) David Montague (7): Disable Google analytics (#5059) prepare for v1.10.6 (#5157) Fix mypy plugin misbehavior with from_orm for user classes (#5193) Mypy plugin: Add implicit defaults for Field with no default argument (#5207) Fix mypy plugin crash (1.10.X-fixes) (#5208) prepare for 1.10.7 (#5248) Fix internal error with mypy (#5449) Dimitri Papadopoulos Orfanos (1): Fix typos found by codespell (#5375) Eric Jolibois (3): fix: support assignment on DataclassProxy (#4880) fix: avoid multiple calls of `__post_init__` when dataclasses are inherited (#4493) fix: use dataclasses proxy for frozen or empty dataclasses (#4878) Gulu Mammadli (1): fix: Fix broken link in the docs (Pydantic Models - Data Binding) (#5074) Hasan Ramezani (11): fix: missing file extension in model_config.md link (#4512) (#4513) Update mkdocs.yml (#4524) (#4532) v2 docs broken link fix (#4533) (#4550) Replace deprecated `get_event_loop` with `asyncio.run` (#4859) (#4860) Fix Literal bug with typing-extension==4.6.0 (#5826) Prepare for 1.10.8 (#5830) Add Pydantic classifier (#5847) [Backport] Fix Decimal trailing zero handling (#5968) Prepare for 1.10.9 (#6034) Add Pydantic `Json` field support to settings management (#6250) Prepare for 1.10.10 (#6308) Jens Heinrich (4): Fix wrong type for parameter (#5127) Mark optional params as Optional (#5128) Use getattr and default for qualname (#5126) tweak type annotations (#5499) Jon Parise (1): Allow dicts to have both patternProperties and additionalProperties (#4641) K900 (1): Fix racy doctests (#6103) Kurt McKee (1): Raise `ValidationError` for unhashable discriminator values (#5132) Kyle Finley (1): update `AnyClassMethod` for change in python/typeshed#9771 (#5505) Marc Mueller (3): [cherry-pick] Fix mypy plugin for 1.1.0 (#5077) (#5111) Don't apply dataclass transform twice with plugin + mypy 1.1.1 (#5162) [cherry-pick] Fix mypy plugin for 1.4.0 (#5927) (#5928) Marcelo Trylesinski (1): ✅ Update FastAPI test script (#6117) Markus Scheidgen (1): Fixed literal validator errors for unhashable values (#6194) MarkusSintonen (1): fix: Fix broken parametrized bases with GenericModels (#5052) Matt Fulgo (2): Allows Optional lists with unique_items check (#4568) Fix TypeError for GenericModel with Callable param (#4653) Mòrian (1): Add postgresql+psycopg as allowed scheme for PostgreDsn (#4689) (#4690) Samuel Colvin (26): test on the 1.10.X-fixes branch fix copy_on_model_validation type hint (#4491) use "field_specifiers", fix #4500 (#4501) add hooky config uprev 3.11, add check job (#4662) Add Jina AI to sponsors (#4767) bust CI cache, fix docs-build bust CI test cache (#4786) Moving docs to `docs.pydantic.dev` (#4818) Reduce binary sizes (#4862) fix history links (#4866) prepare for v1.10.3, fix #4552 Typing extensions min version (#4886) prepare for v1.10.4 release add dependencies-check to 1.10.X-fixes fix install step for dependencies check fix coverage badge to use correct branch (#5060) prepare for v1.10.5 Announcement (#5069) [ALPHA] V2 Alpha Blog Post (#5343) fix link in alpha release to v2 blog Add mike to V1 docs (#5628) enable fastapi testing on 1.10 (#5635) V1 add `build-docs.sh` (#5832) remove sponsors from docs (#5833) add roadmap to announcement (#6120) Serge Matveenko (1): 📌 Use Cython < v3 (#5845) Sigurd Spieckermann (1): [1.10.X] Fix field regex with StrictStr type annotation (#4538) Simon Matejetz (1): Fix creating schema from model using ConstrainedStr with regex str as dict key (#5223) Slava (1): Handle X | Y union in GenericModel (#4977) Volker Hilsenstein (1): Fix broken cross-references (#4743) github-actions[bot] (12): Fix "trough" typo in Model Config docs (#4593) (#4594) Add missing typing to example (#4596) (#4605) Fix improper parsing of Enum document (#4736) Renaming BaseModel (#4766) fix typo in docs (#4765) Remove trailing "```" (#4799) (#4800) Add newline before `Outputs:` when printing json output in docs (#4802) (#4848) Fix typo in types usage documentation. (#4825) (#4849) fixed documentation typo (#4855) (#4858) Fixed datetime format specifier in docs (#4876) (#4879) Fix typo in Field function docstring (#4931) (#4932) Invalidate mypy cache if config changes (#5007) (#5023) gou177 (1): fix: Parsing of custom root models (#4883) (#4884) javibookline (1): Discriminated union literal enum values (#5188) kgolawski (1): Fix code typo in docs (#4775) mark-todd (1): Bug fix for forward refs in generics (#6157) mbillingr (1): Dataclass deepcopy 1.10 (#4963) ⬢ Samuel Colvin (3): remove remains of ads, add custom analytics (#4927) simplify analytics more (#4930) uprev mkdocs-material, fix maxcdn errors (#4954)
1 parent 4f7047f commit 357c58b

File tree

5 files changed

+23
-24
lines changed

5 files changed

+23
-24
lines changed

Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
11
PKG_NAME := pypi-pydantic
2-
URL = https://files.pythonhosted.org/packages/ee/f6/e6f0c9bcb402c1817438491f2ce7480f4f3c179c6e51db13ba8941e94c49/pydantic-2.0.1.tar.gz
2+
URL = https://files.pythonhosted.org/packages/eb/84/9b0a0e2d931fc9bdb32e6905076714f9592f9b20de03c90fd0f65b3ab063/pydantic-1.10.10.tar.gz
33
ARCHIVES =
44

55
include ../common/Makefile.common

options.conf

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
[package]
22
name = pypi-pydantic
3-
url = https://files.pythonhosted.org/packages/ee/f6/e6f0c9bcb402c1817438491f2ce7480f4f3c179c6e51db13ba8941e94c49/pydantic-2.0.1.tar.gz
3+
url = https://files.pythonhosted.org/packages/eb/84/9b0a0e2d931fc9bdb32e6905076714f9592f9b20de03c90fd0f65b3ab063/pydantic-1.10.10.tar.gz
44
archives =
55
giturl = https://github.com/samuelcolvin/pydantic/
66
domain =

pypi-pydantic.spec

+19-20
Original file line numberDiff line numberDiff line change
@@ -1,30 +1,29 @@
11
#
22
# This file is auto-generated. DO NOT EDIT
33
# Generated by: autospec.py
4-
# Using build pattern: pyproject
4+
# Using build pattern: distutils3
55
#
66
Name : pypi-pydantic
7-
Version : 2.0.1
8-
Release : 21
9-
URL : https://files.pythonhosted.org/packages/ee/f6/e6f0c9bcb402c1817438491f2ce7480f4f3c179c6e51db13ba8941e94c49/pydantic-2.0.1.tar.gz
10-
Source0 : https://files.pythonhosted.org/packages/ee/f6/e6f0c9bcb402c1817438491f2ce7480f4f3c179c6e51db13ba8941e94c49/pydantic-2.0.1.tar.gz
7+
Version : 1.10.10
8+
Release : 22
9+
URL : https://files.pythonhosted.org/packages/eb/84/9b0a0e2d931fc9bdb32e6905076714f9592f9b20de03c90fd0f65b3ab063/pydantic-1.10.10.tar.gz
10+
Source0 : https://files.pythonhosted.org/packages/eb/84/9b0a0e2d931fc9bdb32e6905076714f9592f9b20de03c90fd0f65b3ab063/pydantic-1.10.10.tar.gz
1111
Summary : Data validation using Python type hints
1212
Group : Development/Tools
1313
License : MIT
1414
Requires: pypi-pydantic-license = %{version}-%{release}
1515
Requires: pypi-pydantic-python = %{version}-%{release}
1616
Requires: pypi-pydantic-python3 = %{version}-%{release}
1717
BuildRequires : buildreq-distutils3
18-
BuildRequires : pypi(hatch_fancy_pypi_readme)
19-
BuildRequires : pypi(hatchling)
18+
BuildRequires : pypi(typing_extensions)
2019
# Suppress stripping binaries
2120
%define __strip /bin/true
2221
%define debug_package %{nil}
2322

2423
%description
25-
# Pydantic
24+
# pydantic
2625
[![CI](https://github.com/pydantic/pydantic/workflows/CI/badge.svg?event=push)](https://github.com/pydantic/pydantic/actions?query=event%3Apush+branch%3Amain+workflow%3ACI)
27-
[![Coverage](https://coverage-badge.samuelcolvin.workers.dev/pydantic/pydantic.svg)](https://coverage-badge.samuelcolvin.workers.dev/redirect/pydantic/pydantic)
26+
[![Coverage](https://coverage-badge.samuelcolvin.workers.dev/pydantic/pydantic.svg?branch=1.10.X-fixes)](https://coverage-badge.samuelcolvin.workers.dev/redirect/pydantic/pydantic?branch=1.10.X-fixes)
2827
[![pypi](https://img.shields.io/pypi/v/pydantic.svg)](https://pypi.python.org/pypi/pydantic)
2928
[![CondaForge](https://img.shields.io/conda/v/conda-forge/pydantic.svg)](https://anaconda.org/conda-forge/pydantic)
3029
[![downloads](https://pepy.tech/badge/pydantic/month)](https://pepy.tech/project/pydantic)
@@ -62,18 +61,18 @@ python3 components for the pypi-pydantic package.
6261

6362

6463
%prep
65-
%setup -q -n pydantic-2.0.1
66-
cd %{_builddir}/pydantic-2.0.1
64+
%setup -q -n pydantic-1.10.10
65+
cd %{_builddir}/pydantic-1.10.10
6766
pushd ..
68-
cp -a pydantic-2.0.1 buildavx2
67+
cp -a pydantic-1.10.10 buildavx2
6968
popd
7069

7170
%build
7271
export http_proxy=http://127.0.0.1:9/
7372
export https_proxy=http://127.0.0.1:9/
7473
export no_proxy=localhost,127.0.0.1,0.0.0.0
7574
export LANG=C.UTF-8
76-
export SOURCE_DATE_EPOCH=1688572762
75+
export SOURCE_DATE_EPOCH=1688574831
7776
export GCC_IGNORE_WERROR=1
7877
export AR=gcc-ar
7978
export RANLIB=gcc-ranlib
@@ -83,23 +82,23 @@ export FCFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -
8382
export FFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
8483
export CXXFLAGS="$CXXFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
8584
export MAKEFLAGS=%{?_smp_mflags}
86-
python3 -m build --wheel --skip-dependency-check --no-isolation
85+
python3 setup.py build
86+
8787
pushd ../buildavx2/
8888
export CFLAGS="$CFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
8989
export CXXFLAGS="$CXXFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
9090
export FFLAGS="$FFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
9191
export FCFLAGS="$FCFLAGS -m64 -march=x86-64-v3 "
9292
export LDFLAGS="$LDFLAGS -m64 -march=x86-64-v3 "
93-
python3 -m build --wheel --skip-dependency-check --no-isolation
93+
python3 setup.py build
9494

9595
popd
96-
9796
%install
9897
export MAKEFLAGS=%{?_smp_mflags}
9998
rm -rf %{buildroot}
10099
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-pydantic
101-
cp %{_builddir}/pydantic-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-pydantic/cb7f5ccd3d8ef51b9fe19181d2ac801cc59231a4 || :
102-
pip install --root=%{buildroot} --no-deps --ignore-installed dist/*.whl
100+
cp %{_builddir}/pydantic-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-pydantic/f66e0df7b6d8feb97cd45e4fd362d9d412c774b2 || :
101+
python3 -tt setup.py build install --root=%{buildroot}
103102
echo ----[ mark ]----
104103
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
105104
echo ----[ mark ]----
@@ -109,7 +108,7 @@ export CXXFLAGS="$CXXFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
109108
export FFLAGS="$FFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
110109
export FCFLAGS="$FCFLAGS -m64 -march=x86-64-v3 "
111110
export LDFLAGS="$LDFLAGS -m64 -march=x86-64-v3 "
112-
pip install --root=%{buildroot}-v3 --no-deps --ignore-installed dist/*.whl
111+
python3 -tt setup.py build install --root=%{buildroot}-v3
113112
popd
114113
/usr/bin/elf-move.py avx2 %{buildroot}-v3 %{buildroot} %{buildroot}/usr/share/clear/filemap/filemap-%{name}
115114

@@ -118,7 +117,7 @@ popd
118117

119118
%files license
120119
%defattr(0644,root,root,0755)
121-
/usr/share/package-licenses/pypi-pydantic/cb7f5ccd3d8ef51b9fe19181d2ac801cc59231a4
120+
/usr/share/package-licenses/pypi-pydantic/f66e0df7b6d8feb97cd45e4fd362d9d412c774b2
122121

123122
%files python
124123
%defattr(-,root,root,-)

release

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
21
1+
22

upstream

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
81ca3f594c04821ea464ee6df6e3c972a5e146e9/pydantic-2.0.1.tar.gz
1+
8a9e4c6ff238f2fd84a016785c5130d9b4b4a28d/pydantic-1.10.10.tar.gz

0 commit comments

Comments
 (0)