|
4 | 4 | # Using build pattern: distutils3
|
5 | 5 | #
|
6 | 6 | Name : pypi-pydantic
|
7 |
| -Version : 1.10.7 |
8 |
| -Release : 16 |
9 |
| -URL : https://files.pythonhosted.org/packages/43/5f/e53a850fd32dddefc998b6bfcbda843d4ff5b0dcac02a92e414ba6c97d46/pydantic-1.10.7.tar.gz |
10 |
| -Source0 : https://files.pythonhosted.org/packages/43/5f/e53a850fd32dddefc998b6bfcbda843d4ff5b0dcac02a92e414ba6c97d46/pydantic-1.10.7.tar.gz |
| 7 | +Version : 1.10.8 |
| 8 | +Release : 17 |
| 9 | +URL : https://files.pythonhosted.org/packages/23/65/2aa13873e9e0084ecaec00fbe6c6096b65e1ab99ba66bdbf7e4e7c4cc915/pydantic-1.10.8.tar.gz |
| 10 | +Source0 : https://files.pythonhosted.org/packages/23/65/2aa13873e9e0084ecaec00fbe6c6096b65e1ab99ba66bdbf7e4e7c4cc915/pydantic-1.10.8.tar.gz |
11 | 11 | Summary : Data validation and settings management using python type hints
|
12 | 12 | Group : Development/Tools
|
13 | 13 | License : MIT
|
@@ -59,26 +59,26 @@ python3 components for the pypi-pydantic package.
|
59 | 59 |
|
60 | 60 |
|
61 | 61 | %prep
|
62 |
| -%setup -q -n pydantic-1.10.7 |
63 |
| -cd %{_builddir}/pydantic-1.10.7 |
| 62 | +%setup -q -n pydantic-1.10.8 |
| 63 | +cd %{_builddir}/pydantic-1.10.8 |
64 | 64 | pushd ..
|
65 |
| -cp -a pydantic-1.10.7 buildavx2 |
| 65 | +cp -a pydantic-1.10.8 buildavx2 |
66 | 66 | popd
|
67 | 67 |
|
68 | 68 | %build
|
69 | 69 | export http_proxy=http://127.0.0.1:9/
|
70 | 70 | export https_proxy=http://127.0.0.1:9/
|
71 | 71 | export no_proxy=localhost,127.0.0.1,0.0.0.0
|
72 | 72 | export LANG=C.UTF-8
|
73 |
| -export SOURCE_DATE_EPOCH=1679586217 |
| 73 | +export SOURCE_DATE_EPOCH=1684941078 |
74 | 74 | export GCC_IGNORE_WERROR=1
|
75 | 75 | export AR=gcc-ar
|
76 | 76 | export RANLIB=gcc-ranlib
|
77 | 77 | export NM=gcc-nm
|
78 |
| -export CFLAGS="$CFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz " |
79 |
| -export FCFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz " |
80 |
| -export FFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz " |
81 |
| -export CXXFLAGS="$CXXFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz " |
| 78 | +export CFLAGS="$CFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd " |
| 79 | +export FCFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd " |
| 80 | +export FFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd " |
| 81 | +export CXXFLAGS="$CXXFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd " |
82 | 82 | export MAKEFLAGS=%{?_smp_mflags}
|
83 | 83 | python3 setup.py build
|
84 | 84 |
|
|
0 commit comments