Skip to content

Commit 5c07ea8

Browse files
committed
pypi-pydantic: Autospec creation for update from version 1.10.7 to version 1.10.8
Adrian Garcia Badaracco (1): Support for email-validator>=2.0.0.post2 (#5627) Amin Alaee (1): Remove pkg_resources test (#5508) Benoit C. Sirois (1): Fixes discriminated unions not working on aliased literal fields. Issue #3849. (#5736) David Montague (1): Fix internal error with mypy (#5449) Dimitri Papadopoulos Orfanos (1): Fix typos found by codespell (#5375) Hasan Ramezani (2): Fix Literal bug with typing-extension==4.6.0 (#5826) Prepare for 1.10.8 (#5830) Jens Heinrich (1): tweak type annotations (#5499) Kyle Finley (1): update `AnyClassMethod` for change in python/typeshed#9771 (#5505) Samuel Colvin (6): [ALPHA] V2 Alpha Blog Post (#5343) fix link in alpha release to v2 blog Add mike to V1 docs (#5628) enable fastapi testing on 1.10 (#5635) V1 add `build-docs.sh` (#5832) remove sponsors from docs (#5833)
1 parent 56cd38b commit 5c07ea8

File tree

5 files changed

+19
-17
lines changed

5 files changed

+19
-17
lines changed

Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
11
PKG_NAME := pypi-pydantic
2-
URL = https://files.pythonhosted.org/packages/43/5f/e53a850fd32dddefc998b6bfcbda843d4ff5b0dcac02a92e414ba6c97d46/pydantic-1.10.7.tar.gz
2+
URL = https://files.pythonhosted.org/packages/23/65/2aa13873e9e0084ecaec00fbe6c6096b65e1ab99ba66bdbf7e4e7c4cc915/pydantic-1.10.8.tar.gz
33
ARCHIVES =
44

55
include ../common/Makefile.common

options.conf

+4-2
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
[package]
22
name = pypi-pydantic
3-
url = https://files.pythonhosted.org/packages/43/5f/e53a850fd32dddefc998b6bfcbda843d4ff5b0dcac02a92e414ba6c97d46/pydantic-1.10.7.tar.gz
3+
url = https://files.pythonhosted.org/packages/23/65/2aa13873e9e0084ecaec00fbe6c6096b65e1ab99ba66bdbf7e4e7c4cc915/pydantic-1.10.8.tar.gz
44
archives =
55
giturl = https://github.com/samuelcolvin/pydantic/
66
domain =
@@ -19,6 +19,8 @@ autoupdate = true
1919
broken_c++ = false
2020
# disable parallelization during build
2121
broken_parallel_build = false
22+
# create vendor archive with cargo
23+
cargo_vendor = false
2224
# this package is a library compatibility package and only ships versioned library files
2325
compat = false
2426
# set conservative build flags
@@ -58,7 +60,7 @@ skip_tests = false
5860
# add .so files to the lib package instead of dev
5961
so_to_lib = false
6062
# configure build for avx2
61-
use_avx2 = false
63+
use_avx2 = true
6264
# configure build for avx512
6365
use_avx512 = false
6466
# add clang flags

pypi-pydantic.spec

+12-12
Original file line numberDiff line numberDiff line change
@@ -4,10 +4,10 @@
44
# Using build pattern: distutils3
55
#
66
Name : pypi-pydantic
7-
Version : 1.10.7
8-
Release : 16
9-
URL : https://files.pythonhosted.org/packages/43/5f/e53a850fd32dddefc998b6bfcbda843d4ff5b0dcac02a92e414ba6c97d46/pydantic-1.10.7.tar.gz
10-
Source0 : https://files.pythonhosted.org/packages/43/5f/e53a850fd32dddefc998b6bfcbda843d4ff5b0dcac02a92e414ba6c97d46/pydantic-1.10.7.tar.gz
7+
Version : 1.10.8
8+
Release : 17
9+
URL : https://files.pythonhosted.org/packages/23/65/2aa13873e9e0084ecaec00fbe6c6096b65e1ab99ba66bdbf7e4e7c4cc915/pydantic-1.10.8.tar.gz
10+
Source0 : https://files.pythonhosted.org/packages/23/65/2aa13873e9e0084ecaec00fbe6c6096b65e1ab99ba66bdbf7e4e7c4cc915/pydantic-1.10.8.tar.gz
1111
Summary : Data validation and settings management using python type hints
1212
Group : Development/Tools
1313
License : MIT
@@ -59,26 +59,26 @@ python3 components for the pypi-pydantic package.
5959

6060

6161
%prep
62-
%setup -q -n pydantic-1.10.7
63-
cd %{_builddir}/pydantic-1.10.7
62+
%setup -q -n pydantic-1.10.8
63+
cd %{_builddir}/pydantic-1.10.8
6464
pushd ..
65-
cp -a pydantic-1.10.7 buildavx2
65+
cp -a pydantic-1.10.8 buildavx2
6666
popd
6767

6868
%build
6969
export http_proxy=http://127.0.0.1:9/
7070
export https_proxy=http://127.0.0.1:9/
7171
export no_proxy=localhost,127.0.0.1,0.0.0.0
7272
export LANG=C.UTF-8
73-
export SOURCE_DATE_EPOCH=1679586217
73+
export SOURCE_DATE_EPOCH=1684941078
7474
export GCC_IGNORE_WERROR=1
7575
export AR=gcc-ar
7676
export RANLIB=gcc-ranlib
7777
export NM=gcc-nm
78-
export CFLAGS="$CFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
79-
export FCFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
80-
export FFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
81-
export CXXFLAGS="$CXXFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz "
78+
export CFLAGS="$CFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
79+
export FCFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
80+
export FFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
81+
export CXXFLAGS="$CXXFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
8282
export MAKEFLAGS=%{?_smp_mflags}
8383
python3 setup.py build
8484

release

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
16
1+
17

upstream

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
62d7c5937c6a8da36f0c04c6dbc054ca4938f7c4/pydantic-1.10.7.tar.gz
1+
a495345876c18a224a969c7991fa2c7c07b776d9/pydantic-1.10.8.tar.gz

0 commit comments

Comments
 (0)