Skip to content

Commit a82e5db

Browse files
committed
pypi-pytest_runner: Autospec creation for update from version 5.3.1 to version 6.0.0
Alan Fregtman (1): .editorconfig: Set max_line_length to 88 for Python files. Anderson Bravalheri (1): Ignore flake8/black warnings with pytest 7.0.1 (jaraco/skeleton#58) Brian Rutledge (1): Use shutil for rmtree Evangelos Foutras (1): test_egg_fetcher: use newer setuptools on Python 3.10 Jason R. Coombs (35): Rebrand to 'For Enterprise' Add a 'For Enterprise' section to the README Include token passthrough for azure pipelines publish stage. Move Tidelift release note publishing to Github Actions. Tidelift no longer requires or expects publishing release notes. Remove Tidelift from main.yml, no longer needed Test on Python 3.10 Remove setup_requires, obviated by build-requires in pyproject.toml. Suppress deprecation warnings in flake8 and packaging.tags. Ref pypa/packaging#433. Rely on setuptools 56 and drop the explicit mention of the license file in favor of simple discovery. Remove workaround for python/typed_ast#156. Use line continuations to indicate which exclusions are for which workarounds. Fix syntax issue in changelog. Fixes #58. Implement tidelift banner using a Sphinx directive implemented by jaraco.tidelift. Remove blacken docs as it cannot honor Python's default repr. Ref adamchainz/blacken-docs#62. Add intersphinx mappings for Python to prevent spurious nitpicky failures. Fixes jaraco/skeleton#51. Test on Python 3.10 (final). Rely on pytest 6 and drop workaround for pytest-dev/pytest#6178. Remove wheel from build requirements. It's implied for wheel builds. Ref pypa/setuptools#1498. Require Python 3.7 or later. Remove filtered warnings, addressed upstream. Update badge year Remove setup.py, no longer needed. Add exclusions for pytest 7 deprecations in plugins. Fixes jaraco/skeleton#57. Use the parent category PytestDeprecationWarning, which is available on older pytest versions. Fixes jaraco/skeleton#57. Bump pytest-mypy and remove workaround for realpython/pytest-mypy#131. Require jaraco.packaging 9 adding compatibility for projects with no setup.py file. Ran pre-commit autoupdate 🧎‍♀️ Genuflect to the types. Update test to install pytest-runner using pip. Tests no longer run on Python 3.6 Update changelog. Remove legacy code ⚫ Fade to black. Move module to package for simplicity of packaging.
1 parent cc986f6 commit a82e5db

File tree

7 files changed

+15
-14
lines changed

7 files changed

+15
-14
lines changed

Makefile

Lines changed: 1 addition & 1 deletion
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
11
PKG_NAME := pypi-pytest_runner
2-
URL = https://files.pythonhosted.org/packages/2a/04/c3223812b3427ffa95110c5781eae7fe8bc3e9e1fe4e2328bee17b9e5820/pytest-runner-5.3.1.tar.gz
2+
URL = https://files.pythonhosted.org/packages/2b/b2/5a07a37f314d3c0457c5431fd5b130e04355fa143f042356f77dd1570d36/pytest-runner-6.0.0.tar.gz
33
ARCHIVES =
44

55
include ../common/Makefile.common

options.conf

Lines changed: 1 addition & 1 deletion
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
[package]
22
name = pypi-pytest_runner
3-
url = https://files.pythonhosted.org/packages/2a/04/c3223812b3427ffa95110c5781eae7fe8bc3e9e1fe4e2328bee17b9e5820/pytest-runner-5.3.1.tar.gz
3+
url = https://files.pythonhosted.org/packages/2b/b2/5a07a37f314d3c0457c5431fd5b130e04355fa143f042356f77dd1570d36/pytest-runner-6.0.0.tar.gz
44
archives =
55
giturl = https://github.com/pytest-dev/pytest-runner.git
66
domain =

pypi-pytest_runner.spec

Lines changed: 8 additions & 9 deletions
Original file line numberDiff line numberDiff line change
@@ -3,10 +3,10 @@
33
# Generated by: autospec.py
44
#
55
Name : pypi-pytest_runner
6-
Version : 5.3.1
7-
Release : 71
8-
URL : https://files.pythonhosted.org/packages/2a/04/c3223812b3427ffa95110c5781eae7fe8bc3e9e1fe4e2328bee17b9e5820/pytest-runner-5.3.1.tar.gz
9-
Source0 : https://files.pythonhosted.org/packages/2a/04/c3223812b3427ffa95110c5781eae7fe8bc3e9e1fe4e2328bee17b9e5820/pytest-runner-5.3.1.tar.gz
6+
Version : 6.0.0
7+
Release : 72
8+
URL : https://files.pythonhosted.org/packages/2b/b2/5a07a37f314d3c0457c5431fd5b130e04355fa143f042356f77dd1570d36/pytest-runner-6.0.0.tar.gz
9+
Source0 : https://files.pythonhosted.org/packages/2b/b2/5a07a37f314d3c0457c5431fd5b130e04355fa143f042356f77dd1570d36/pytest-runner-6.0.0.tar.gz
1010
Summary : Invoke py.test as distutils command with dependency resolution
1111
Group : Development/Tools
1212
License : MIT
@@ -17,7 +17,6 @@ BuildRequires : buildreq-distutils3
1717
BuildRequires : pypi(py)
1818
BuildRequires : pypi(setuptools)
1919
BuildRequires : pypi(setuptools_scm)
20-
BuildRequires : pypi(wheel)
2120
BuildRequires : pypi-pluggy
2221
BuildRequires : pypi-pytest
2322
BuildRequires : pypi-tox
@@ -55,15 +54,15 @@ python3 components for the pypi-pytest_runner package.
5554

5655

5756
%prep
58-
%setup -q -n pytest-runner-5.3.1
59-
cd %{_builddir}/pytest-runner-5.3.1
57+
%setup -q -n pytest-runner-6.0.0
58+
cd %{_builddir}/pytest-runner-6.0.0
6059

6160
%build
6261
export http_proxy=http://127.0.0.1:9/
6362
export https_proxy=http://127.0.0.1:9/
6463
export no_proxy=localhost,127.0.0.1,0.0.0.0
6564
export LANG=C.UTF-8
66-
export SOURCE_DATE_EPOCH=1642463510
65+
export SOURCE_DATE_EPOCH=1645917778
6766
export GCC_IGNORE_WERROR=1
6867
export AR=gcc-ar
6968
export RANLIB=gcc-ranlib
@@ -79,7 +78,7 @@ python3 -m build --wheel --skip-dependency-check --no-isolation
7978
export MAKEFLAGS=%{?_smp_mflags}
8079
rm -rf %{buildroot}
8180
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-pytest_runner
82-
cp %{_builddir}/pytest-runner-5.3.1/LICENSE %{buildroot}/usr/share/package-licenses/pypi-pytest_runner/8e6689d37f82d5617b7f7f7232c94024d41066d1
81+
cp %{_builddir}/pytest-runner-6.0.0/LICENSE %{buildroot}/usr/share/package-licenses/pypi-pytest_runner/8e6689d37f82d5617b7f7f7232c94024d41066d1
8382
pip install --root=%{buildroot} --no-deps --ignore-installed dist/*.whl
8483
echo ----[ mark ]----
8584
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :

release

Lines changed: 1 addition & 1 deletion
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
71
1+
72

upstream

Lines changed: 1 addition & 1 deletion
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
4787d20ef8f4f705ffec26bfc0b27cfe61479a30/pytest-runner-5.3.1.tar.gz
1+
b13e48a67ea39890f3d05c8b185b6dfa3f6c1e10/pytest-runner-6.0.0.tar.gz

versions

Lines changed: 1 addition & 1 deletion
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
5.3.1
1+
6.0.0

whatrequires

Lines changed: 2 additions & 0 deletions
Original file line numberDiff line numberDiff line change
@@ -1 +1,3 @@
11
# This file contains recursive sources that require this package
2+
pypi-aiohttp_cors
3+
pypi-pyjwt

0 commit comments

Comments
 (0)