Skip to content

Commit bebea0c

Browse files
authored
[Windows] Add a flutter run console output test (#116626)
Adds a test to verify the console output of `flutter run --release` on Windows. Part of: flutter/flutter#111577
1 parent 003608f commit bebea0c

19 files changed

+1130
-2
lines changed

.ci.yaml

+18
Original file line numberDiff line numberDiff line change
@@ -4193,6 +4193,24 @@ targets:
41934193
- bin/**
41944194
- .ci.yaml
41954195

4196+
- name: Windows run_release_test_windows
4197+
bringup: true
4198+
recipe: devicelab/devicelab_drone
4199+
timeout: 60
4200+
properties:
4201+
dependencies: >-
4202+
[
4203+
{"dependency": "vs_build", "version": "version:vs2019"}
4204+
]
4205+
tags: >
4206+
["devicelab", "hostonly", "windows"]
4207+
task_name: run_release_test_windows
4208+
runIf:
4209+
- dev/**
4210+
- packages/flutter_tools/**
4211+
- bin/**
4212+
- .ci.yaml
4213+
41964214
- name: Windows tool_integration_tests_1_6
41974215
recipe: flutter/flutter_drone
41984216
timeout: 60

TESTOWNERS

+1
Original file line numberDiff line numberDiff line change
@@ -250,6 +250,7 @@
250250
/dev/devicelab/bin/tasks/plugin_test_ios.dart @jmagman @flutter/ios
251251
/dev/devicelab/bin/tasks/plugin_test.dart @stuartmorgan @flutter/plugin
252252
/dev/devicelab/bin/tasks/run_release_test_macos.dart @cbracken @flutter/tool
253+
/dev/devicelab/bin/tasks/run_release_test_windows.dart @loic-sharma @flutter/tool
253254
/dev/devicelab/bin/tasks/technical_debt__cost.dart @HansMuller @flutter/framework
254255
/dev/devicelab/bin/tasks/web_benchmarks_canvaskit.dart @yjbanov @flutter/web
255256
/dev/devicelab/bin/tasks/web_benchmarks_html.dart @yjbanov @flutter/web
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,12 @@
1+
// Copyright 2014 The Flutter Authors. All rights reserved.
2+
// Use of this source code is governed by a BSD-style license that can be
3+
// found in the LICENSE file.
4+
5+
import 'package:flutter_devicelab/framework/devices.dart';
6+
import 'package:flutter_devicelab/framework/framework.dart';
7+
import 'package:flutter_devicelab/tasks/run_tests.dart';
8+
9+
Future<void> main() async {
10+
deviceOperatingSystem = DeviceOperatingSystem.windows;
11+
await task(createWindowsRunReleaseTest());
12+
}

dev/devicelab/lib/tasks/run_tests.dart

+10-2
Original file line numberDiff line numberDiff line change
@@ -26,6 +26,14 @@ TaskFunction createMacOSRunReleaseTest() {
2626
);
2727
}
2828

29+
TaskFunction createWindowsRunReleaseTest() {
30+
return DesktopRunOutputTest(
31+
'${flutterDirectory.path}/dev/integration_tests/ui',
32+
'lib/empty.dart',
33+
release: true,
34+
);
35+
}
36+
2937
class AndroidRunOutputTest extends RunOutputTask {
3038
AndroidRunOutputTest({required super.release}) : super(
3139
'${flutterDirectory.path}/dev/integration_tests/ui',
@@ -130,9 +138,9 @@ class DesktopRunOutputTest extends RunOutputTask {
130138
TaskResult verify(List<String> stdout, List<String> stderr) {
131139
_findNextMatcherInList(
132140
stdout,
133-
(String line) => line.startsWith('Launching lib/main.dart on ') &&
141+
(String line) => line.startsWith('Launching $testTarget on ') &&
134142
line.endsWith(' in ${release ? 'release' : 'debug'} mode...'),
135-
'Launching lib/main.dart on',
143+
'Launching $testTarget on',
136144
);
137145

138146
_findNextMatcherInList(
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,17 @@
1+
flutter/ephemeral/
2+
3+
# Visual Studio user-specific files.
4+
*.suo
5+
*.user
6+
*.userosscache
7+
*.sln.docstates
8+
9+
# Visual Studio build-related files.
10+
x64/
11+
x86/
12+
13+
# Visual Studio cache files
14+
# files ending in .cache can be ignored
15+
*.[Cc]ache
16+
# but keep track of directories ending in .cache
17+
!*.[Cc]ache/
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,101 @@
1+
# Project-level configuration.
2+
cmake_minimum_required(VERSION 3.14)
3+
project(ui LANGUAGES CXX)
4+
5+
# The name of the executable created for the application. Change this to change
6+
# the on-disk name of your application.
7+
set(BINARY_NAME "ui")
8+
9+
# Explicitly opt in to modern CMake behaviors to avoid warnings with recent
10+
# versions of CMake.
11+
cmake_policy(SET CMP0063 NEW)
12+
13+
# Define build configuration option.
14+
get_property(IS_MULTICONFIG GLOBAL PROPERTY GENERATOR_IS_MULTI_CONFIG)
15+
if(IS_MULTICONFIG)
16+
set(CMAKE_CONFIGURATION_TYPES "Debug;Profile;Release"
17+
CACHE STRING "" FORCE)
18+
else()
19+
if(NOT CMAKE_BUILD_TYPE AND NOT CMAKE_CONFIGURATION_TYPES)
20+
set(CMAKE_BUILD_TYPE "Debug" CACHE
21+
STRING "Flutter build mode" FORCE)
22+
set_property(CACHE CMAKE_BUILD_TYPE PROPERTY STRINGS
23+
"Debug" "Profile" "Release")
24+
endif()
25+
endif()
26+
# Define settings for the Profile build mode.
27+
set(CMAKE_EXE_LINKER_FLAGS_PROFILE "${CMAKE_EXE_LINKER_FLAGS_RELEASE}")
28+
set(CMAKE_SHARED_LINKER_FLAGS_PROFILE "${CMAKE_SHARED_LINKER_FLAGS_RELEASE}")
29+
set(CMAKE_C_FLAGS_PROFILE "${CMAKE_C_FLAGS_RELEASE}")
30+
set(CMAKE_CXX_FLAGS_PROFILE "${CMAKE_CXX_FLAGS_RELEASE}")
31+
32+
# Use Unicode for all projects.
33+
add_definitions(-DUNICODE -D_UNICODE)
34+
35+
# Compilation settings that should be applied to most targets.
36+
#
37+
# Be cautious about adding new options here, as plugins use this function by
38+
# default. In most cases, you should add new options to specific targets instead
39+
# of modifying this function.
40+
function(APPLY_STANDARD_SETTINGS TARGET)
41+
target_compile_features(${TARGET} PUBLIC cxx_std_17)
42+
target_compile_options(${TARGET} PRIVATE /W4 /WX /wd"4100")
43+
target_compile_options(${TARGET} PRIVATE /EHsc)
44+
target_compile_definitions(${TARGET} PRIVATE "_HAS_EXCEPTIONS=0")
45+
target_compile_definitions(${TARGET} PRIVATE "$<$<CONFIG:Debug>:_DEBUG>")
46+
endfunction()
47+
48+
# Flutter library and tool build rules.
49+
set(FLUTTER_MANAGED_DIR "${CMAKE_CURRENT_SOURCE_DIR}/flutter")
50+
add_subdirectory(${FLUTTER_MANAGED_DIR})
51+
52+
# Application build; see runner/CMakeLists.txt.
53+
add_subdirectory("runner")
54+
55+
# Generated plugin build rules, which manage building the plugins and adding
56+
# them to the application.
57+
include(flutter/generated_plugins.cmake)
58+
59+
60+
# === Installation ===
61+
# Support files are copied into place next to the executable, so that it can
62+
# run in place. This is done instead of making a separate bundle (as on Linux)
63+
# so that building and running from within Visual Studio will work.
64+
set(BUILD_BUNDLE_DIR "$<TARGET_FILE_DIR:${BINARY_NAME}>")
65+
# Make the "install" step default, as it's required to run.
66+
set(CMAKE_VS_INCLUDE_INSTALL_TO_DEFAULT_BUILD 1)
67+
if(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
68+
set(CMAKE_INSTALL_PREFIX "${BUILD_BUNDLE_DIR}" CACHE PATH "..." FORCE)
69+
endif()
70+
71+
set(INSTALL_BUNDLE_DATA_DIR "${CMAKE_INSTALL_PREFIX}/data")
72+
set(INSTALL_BUNDLE_LIB_DIR "${CMAKE_INSTALL_PREFIX}")
73+
74+
install(TARGETS ${BINARY_NAME} RUNTIME DESTINATION "${CMAKE_INSTALL_PREFIX}"
75+
COMPONENT Runtime)
76+
77+
install(FILES "${FLUTTER_ICU_DATA_FILE}" DESTINATION "${INSTALL_BUNDLE_DATA_DIR}"
78+
COMPONENT Runtime)
79+
80+
install(FILES "${FLUTTER_LIBRARY}" DESTINATION "${INSTALL_BUNDLE_LIB_DIR}"
81+
COMPONENT Runtime)
82+
83+
if(PLUGIN_BUNDLED_LIBRARIES)
84+
install(FILES "${PLUGIN_BUNDLED_LIBRARIES}"
85+
DESTINATION "${INSTALL_BUNDLE_LIB_DIR}"
86+
COMPONENT Runtime)
87+
endif()
88+
89+
# Fully re-copy the assets directory on each build to avoid having stale files
90+
# from a previous install.
91+
set(FLUTTER_ASSET_DIR_NAME "flutter_assets")
92+
install(CODE "
93+
file(REMOVE_RECURSE \"${INSTALL_BUNDLE_DATA_DIR}/${FLUTTER_ASSET_DIR_NAME}\")
94+
" COMPONENT Runtime)
95+
install(DIRECTORY "${PROJECT_BUILD_DIR}/${FLUTTER_ASSET_DIR_NAME}"
96+
DESTINATION "${INSTALL_BUNDLE_DATA_DIR}" COMPONENT Runtime)
97+
98+
# Install the AOT library on non-Debug builds only.
99+
install(FILES "${AOT_LIBRARY}" DESTINATION "${INSTALL_BUNDLE_DATA_DIR}"
100+
CONFIGURATIONS Profile;Release
101+
COMPONENT Runtime)
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,104 @@
1+
# This file controls Flutter-level build steps. It should not be edited.
2+
cmake_minimum_required(VERSION 3.14)
3+
4+
set(EPHEMERAL_DIR "${CMAKE_CURRENT_SOURCE_DIR}/ephemeral")
5+
6+
# Configuration provided via flutter tool.
7+
include(${EPHEMERAL_DIR}/generated_config.cmake)
8+
9+
# TODO: Move the rest of this into files in ephemeral. See
10+
# https://github.com/flutter/flutter/issues/57146.
11+
set(WRAPPER_ROOT "${EPHEMERAL_DIR}/cpp_client_wrapper")
12+
13+
# === Flutter Library ===
14+
set(FLUTTER_LIBRARY "${EPHEMERAL_DIR}/flutter_windows.dll")
15+
16+
# Published to parent scope for install step.
17+
set(FLUTTER_LIBRARY ${FLUTTER_LIBRARY} PARENT_SCOPE)
18+
set(FLUTTER_ICU_DATA_FILE "${EPHEMERAL_DIR}/icudtl.dat" PARENT_SCOPE)
19+
set(PROJECT_BUILD_DIR "${PROJECT_DIR}/build/" PARENT_SCOPE)
20+
set(AOT_LIBRARY "${PROJECT_DIR}/build/windows/app.so" PARENT_SCOPE)
21+
22+
list(APPEND FLUTTER_LIBRARY_HEADERS
23+
"flutter_export.h"
24+
"flutter_windows.h"
25+
"flutter_messenger.h"
26+
"flutter_plugin_registrar.h"
27+
"flutter_texture_registrar.h"
28+
)
29+
list(TRANSFORM FLUTTER_LIBRARY_HEADERS PREPEND "${EPHEMERAL_DIR}/")
30+
add_library(flutter INTERFACE)
31+
target_include_directories(flutter INTERFACE
32+
"${EPHEMERAL_DIR}"
33+
)
34+
target_link_libraries(flutter INTERFACE "${FLUTTER_LIBRARY}.lib")
35+
add_dependencies(flutter flutter_assemble)
36+
37+
# === Wrapper ===
38+
list(APPEND CPP_WRAPPER_SOURCES_CORE
39+
"core_implementations.cc"
40+
"standard_codec.cc"
41+
)
42+
list(TRANSFORM CPP_WRAPPER_SOURCES_CORE PREPEND "${WRAPPER_ROOT}/")
43+
list(APPEND CPP_WRAPPER_SOURCES_PLUGIN
44+
"plugin_registrar.cc"
45+
)
46+
list(TRANSFORM CPP_WRAPPER_SOURCES_PLUGIN PREPEND "${WRAPPER_ROOT}/")
47+
list(APPEND CPP_WRAPPER_SOURCES_APP
48+
"flutter_engine.cc"
49+
"flutter_view_controller.cc"
50+
)
51+
list(TRANSFORM CPP_WRAPPER_SOURCES_APP PREPEND "${WRAPPER_ROOT}/")
52+
53+
# Wrapper sources needed for a plugin.
54+
add_library(flutter_wrapper_plugin STATIC
55+
${CPP_WRAPPER_SOURCES_CORE}
56+
${CPP_WRAPPER_SOURCES_PLUGIN}
57+
)
58+
apply_standard_settings(flutter_wrapper_plugin)
59+
set_target_properties(flutter_wrapper_plugin PROPERTIES
60+
POSITION_INDEPENDENT_CODE ON)
61+
set_target_properties(flutter_wrapper_plugin PROPERTIES
62+
CXX_VISIBILITY_PRESET hidden)
63+
target_link_libraries(flutter_wrapper_plugin PUBLIC flutter)
64+
target_include_directories(flutter_wrapper_plugin PUBLIC
65+
"${WRAPPER_ROOT}/include"
66+
)
67+
add_dependencies(flutter_wrapper_plugin flutter_assemble)
68+
69+
# Wrapper sources needed for the runner.
70+
add_library(flutter_wrapper_app STATIC
71+
${CPP_WRAPPER_SOURCES_CORE}
72+
${CPP_WRAPPER_SOURCES_APP}
73+
)
74+
apply_standard_settings(flutter_wrapper_app)
75+
target_link_libraries(flutter_wrapper_app PUBLIC flutter)
76+
target_include_directories(flutter_wrapper_app PUBLIC
77+
"${WRAPPER_ROOT}/include"
78+
)
79+
add_dependencies(flutter_wrapper_app flutter_assemble)
80+
81+
# === Flutter tool backend ===
82+
# _phony_ is a non-existent file to force this command to run every time,
83+
# since currently there's no way to get a full input/output list from the
84+
# flutter tool.
85+
set(PHONY_OUTPUT "${CMAKE_CURRENT_BINARY_DIR}/_phony_")
86+
set_source_files_properties("${PHONY_OUTPUT}" PROPERTIES SYMBOLIC TRUE)
87+
add_custom_command(
88+
OUTPUT ${FLUTTER_LIBRARY} ${FLUTTER_LIBRARY_HEADERS}
89+
${CPP_WRAPPER_SOURCES_CORE} ${CPP_WRAPPER_SOURCES_PLUGIN}
90+
${CPP_WRAPPER_SOURCES_APP}
91+
${PHONY_OUTPUT}
92+
COMMAND ${CMAKE_COMMAND} -E env
93+
${FLUTTER_TOOL_ENVIRONMENT}
94+
"${FLUTTER_ROOT}/packages/flutter_tools/bin/tool_backend.bat"
95+
windows-x64 $<CONFIG>
96+
VERBATIM
97+
)
98+
add_custom_target(flutter_assemble DEPENDS
99+
"${FLUTTER_LIBRARY}"
100+
${FLUTTER_LIBRARY_HEADERS}
101+
${CPP_WRAPPER_SOURCES_CORE}
102+
${CPP_WRAPPER_SOURCES_PLUGIN}
103+
${CPP_WRAPPER_SOURCES_APP}
104+
)
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,23 @@
1+
#
2+
# Generated file, do not edit.
3+
#
4+
5+
list(APPEND FLUTTER_PLUGIN_LIST
6+
)
7+
8+
list(APPEND FLUTTER_FFI_PLUGIN_LIST
9+
)
10+
11+
set(PLUGIN_BUNDLED_LIBRARIES)
12+
13+
foreach(plugin ${FLUTTER_PLUGIN_LIST})
14+
add_subdirectory(flutter/ephemeral/.plugin_symlinks/${plugin}/windows plugins/${plugin})
15+
target_link_libraries(${BINARY_NAME} PRIVATE ${plugin}_plugin)
16+
list(APPEND PLUGIN_BUNDLED_LIBRARIES $<TARGET_FILE:${plugin}_plugin>)
17+
list(APPEND PLUGIN_BUNDLED_LIBRARIES ${${plugin}_bundled_libraries})
18+
endforeach(plugin)
19+
20+
foreach(ffi_plugin ${FLUTTER_FFI_PLUGIN_LIST})
21+
add_subdirectory(flutter/ephemeral/.plugin_symlinks/${ffi_plugin}/windows plugins/${ffi_plugin})
22+
list(APPEND PLUGIN_BUNDLED_LIBRARIES ${${ffi_plugin}_bundled_libraries})
23+
endforeach(ffi_plugin)
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,40 @@
1+
cmake_minimum_required(VERSION 3.14)
2+
project(runner LANGUAGES CXX)
3+
4+
# Define the application target. To change its name, change BINARY_NAME in the
5+
# top-level CMakeLists.txt, not the value here, or `flutter run` will no longer
6+
# work.
7+
#
8+
# Any new source files that you add to the application should be added here.
9+
add_executable(${BINARY_NAME} WIN32
10+
"flutter_window.cpp"
11+
"main.cpp"
12+
"utils.cpp"
13+
"win32_window.cpp"
14+
"${FLUTTER_MANAGED_DIR}/generated_plugin_registrant.cc"
15+
"Runner.rc"
16+
"runner.exe.manifest"
17+
)
18+
19+
# Apply the standard set of build settings. This can be removed for applications
20+
# that need different build settings.
21+
apply_standard_settings(${BINARY_NAME})
22+
23+
# Add preprocessor definitions for the build version.
24+
target_compile_definitions(${BINARY_NAME} PRIVATE "FLUTTER_VERSION=\"${FLUTTER_VERSION}\"")
25+
target_compile_definitions(${BINARY_NAME} PRIVATE "FLUTTER_VERSION_MAJOR=${FLUTTER_VERSION_MAJOR}")
26+
target_compile_definitions(${BINARY_NAME} PRIVATE "FLUTTER_VERSION_MINOR=${FLUTTER_VERSION_MINOR}")
27+
target_compile_definitions(${BINARY_NAME} PRIVATE "FLUTTER_VERSION_PATCH=${FLUTTER_VERSION_PATCH}")
28+
target_compile_definitions(${BINARY_NAME} PRIVATE "FLUTTER_VERSION_BUILD=${FLUTTER_VERSION_BUILD}")
29+
30+
# Disable Windows macros that collide with C++ standard library functions.
31+
target_compile_definitions(${BINARY_NAME} PRIVATE "NOMINMAX")
32+
33+
# Add dependency libraries and include directories. Add any application-specific
34+
# dependencies here.
35+
target_link_libraries(${BINARY_NAME} PRIVATE flutter flutter_wrapper_app)
36+
target_link_libraries(${BINARY_NAME} PRIVATE "dwmapi.lib")
37+
target_include_directories(${BINARY_NAME} PRIVATE "${CMAKE_SOURCE_DIR}")
38+
39+
# Run the Flutter tool portions of the build. This must not be removed.
40+
add_dependencies(${BINARY_NAME} flutter_assemble)

0 commit comments

Comments
 (0)