Skip to content

Commit 685d47c

Browse files
committed
need to patch pandas to not care about versioneered version, set SHELL to bash explicitly to not mess with zsh -e
1 parent d8d2fbf commit 685d47c

File tree

3 files changed

+18
-2
lines changed

3 files changed

+18
-2
lines changed
Lines changed: 11 additions & 0 deletions
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,11 @@
1+
--- a/pandas/__init__.py
2+
+++ b/pandas/__init__.py
3+
@@ -57,7 +57,4 @@ from pandas.util.print_versions import s
4+
import pandas.util.testing
5+
6+
# use the closest tagged version if possible
7+
-from ._version import get_versions
8+
-v = get_versions()
9+
-__version__ = v.get('closest-tag',v['version'])
10+
-del get_versions, v
11+
+from .version import version as __version__

debian/patches/series

Lines changed: 1 addition & 0 deletions
Original file line numberDiff line numberDiff line change
@@ -1,3 +1,4 @@
1+
deb_nonversioneer_version
12
changeset_d84d8f9399e2a86ebaa972d7dbcbc85043b3fb62.diff
23
deb_doc_donotoverride_PYTHONPATH
34
deb_skip_test_precision_i386

debian/rules

Lines changed: 6 additions & 2 deletions
Original file line numberDiff line numberDiff line change
@@ -18,7 +18,9 @@ PY3VERS = $(shell py3versions -vr)
1818
PY3VER = $(shell py3versions -vd)
1919

2020
UVER := $(shell LC_ALL=C dpkg-parsechangelog | awk '/^Version:/{print $$2;}' | sed -e 's,-[^-]*$$,,g')
21-
UVER_SHORT := $(shell echo $(UVER) | sed -e 's,[~],,g' -e 's,+git.*,,g')
21+
# Python doesn't use ~ for rc
22+
UVER_PY := $(shell echo $(UVER) | sed -e 's,[~],,g')
23+
UVER_PYSHORT := $(shell echo $(UVER_PY) | sed -e 's,+git.*,,g')
2224

2325
MIN_CYTHONVER = 0.20.2
2426

@@ -37,6 +39,8 @@ EXCLUDE_TESTS3.3 :=
3739
export http_proxy=http://127.0.0.1:9/
3840
export https_proxy=http://127.0.0.1:9/
3941

42+
export SHELL=/bin/bash
43+
4044
# Mega rule
4145
%:
4246
: # Explicit build system to avoid use of all-in-1 Makefile
@@ -78,7 +82,7 @@ override_dh_clean: clean_generated
7882

7983
version_py:
8084
[ -e pandas/version.py ] || \
81-
echo -e "version = '$(UVER)'\nshort_version = '$(UVER_SHORT)'" > pandas/version.py
85+
echo -e "version = '$(UVER_PY)'\nshort_version = '$(UVER_PYSHORT)'" > pandas/version.py
8286

8387
override_dh_auto_build: version_py
8488
# Override default build operation which --force's re-cythonization

0 commit comments

Comments
 (0)